Commit 23b7c0be authored by Anthony Mallet's avatar Anthony Mallet

[wip/qt-osgqt] Move to robotpkg

Affected packages:
* hpp-benchmark
parent 4c0bda09
......@@ -120,7 +120,6 @@ SUBDIR+= py-talos-rbprm
SUBDIR+= py-talos-torque-control
SUBDIR+= py-tiago-tutorials
SUBDIR+= pyrene-motions
SUBDIR+= qt-osgqt
SUBDIR+= roralink
SUBDIR+= ros-aicp-mapping
SUBDIR+= ros-four-wheel-steering-msgs
......
......@@ -27,13 +27,13 @@ include ../../graphics/openscenegraph/depend.mk
include ../../graphics/py-qt-gepetto-viewer/depend.mk
include ../../graphics/py-qt-gepetto-viewer-corba/depend.mk
include ../../graphics/py-qt-hpp-gepetto-viewer/depend.mk
include ../../graphics/qt-osgqt/depend.mk
include ../../math/hpp-pinocchio/depend.mk
include ../../middleware/omniORB/depend.mk
include ../../path/py-hpp-corbaserver/depend.mk
include ../../path/hpp-constraints/depend.mk
include ../../path/hpp-core/depend.mk
include ../../robots/romeo-description/depend.mk
include ../../mk/sysdep/openscenegraph-qt.mk
include ../../mk/sysdep/openthreads.mk
include ../../mk/sysdep/python.mk
include ../../mk/sysdep/qt.mk
......
This is a Qt project for making use of OpenSceneGraph(OSG)
# robotpkg Makefile for: graphics/qt4-osgQt
# Created: Guilhem Saurel on Mon, 25 May 2020
#
ORG= gepetto
NAME= osgQt
VERSION= 3.5.7
DISTNAME= ${VERSION}
MASTER_SITES= ${MASTER_SITE_GITHUB:=${ORG}/${NAME}}/archive/
WRKSRC= ${WRKDIR}/${NAME}-${DISTNAME}
PKGNAME= ${PKGTAG.qt-}${NAME}-${VERSION}
CATEGORIES= graphics
COMMENT= open source high performance 3D graphics toolkit
LICENSE= gnu-lgpl-v2.1
MAINTAINER= gsaurel@laas.fr
CMAKE_ARGS+= -DDESIRED_QT_VERSION=${QT_SELECT}
CMAKE_ARGS+= -DLIB_POSTFIX=""
CMAKE_PREFIX_PATH= ${PREFIX.openscenegraph}
PLIST_SRC+= ${PKGDIR}/PLIST
PLIST_SRC+= ${PKGDIR}/PLIST.${PKG_ALTERNATIVE.qt}
include ../../wip/openscenegraph/depend.mk
include ../../mk/sysdep/qt.mk
include ../../mk/sysdep/cmake.mk
include ../../mk/language/c.mk
include ../../mk/language/c++11.mk
include ../../mk/robotpkg.mk
@comment Tue Jun 16 12:53:13 CEST 2020
include/osgQt/Export
include/osgQt/GraphicsWindowQt
include/osgQt/QFontImplementation
include/osgQt/QGraphicsViewAdapter
include/osgQt/QWebViewImage
include/osgQt/QWidgetImage
lib/libosgQt.so
lib/libosgQt.so.145
lib/libosgQt.so.3.6.5
lib/pkgconfig/openscenegraph-osgQt.pc
lib/libosgQt5.so
lib/libosgQt5.so.145
lib/libosgQt5.so.3.6.5
lib/pkgconfig/openscenegraph-osgQt5.pc
# robotpkg depend.mk for: graphics/qt4-osgQt
# Created: Guilhem Saurel on Mon, 25 May 2020
#
DEPEND_DEPTH:= ${DEPEND_DEPTH}+
OSGQT_DEPEND_MK:= ${OSGQT_DEPEND_MK}+
ifeq (+,$(DEPEND_DEPTH))
DEPEND_PKG+= qt-osgqt
endif
ifeq (+,$(OSGQT_DEPEND_MK)) # -------------------------------------
DEPEND_USE+= qt-osgqt
DEPEND_ABI.qt-osgqt?= ${PKGTAG.qt-}osgQt>=3.5
DEPEND_DIR.qt-osgqt?= ../../wip/qt-osgqt
SYSTEM_SEARCH.qt-osgqt= \
'include/osgQt/Export' \
'lib/libosgQt{,5}.so' \
'lib/pkgconfig/openscenegraph-osgQt{,5}.pc:/Version/s/[^0-9.]//gp'
include ../../mk/sysdep/qt.mk
endif # OSGQT_DEPEND_MK -------------------------------------------
DEPEND_DEPTH:= ${DEPEND_DEPTH:+=}
SHA1 (3.5.7.tar.gz) = b26af6627775f39361207c85f8591f6bfe23782d
RMD160 (3.5.7.tar.gz) = 85bb3a0be847c35cf58301815725160408d191d8
Size (3.5.7.tar.gz) = 1000217 bytes
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment