Commit 941bf036 authored by Guilhem Saurel's avatar Guilhem Saurel

[wip/py-{qt- → }pythonqt] Rename

As pythonqt v3.2 is not compatible with Qt4 anymore
parent fd920861
......@@ -99,7 +99,7 @@ SUBDIR+= py-prf-ros-controllers
SUBDIR+= py-pycddlib
SUBDIR+= py-qpoases
SUBDIR+= py-qt-gepetto-pythonqt
SUBDIR+= py-qt-pythonqt
SUBDIR+= py-pythonqt
SUBDIR+= py-ros-baxter-common
SUBDIR+= py-roscontrol-sot
SUBDIR+= py-scs
......
# robotpkg Makefile for: wip/py38-qt5-PythonQt
# robotpkg Makefile for: wip/py38-PythonQt
# Created: Guilhem Saurel on Wed, 27 May 2020
#
......@@ -7,7 +7,7 @@ NAME= PythonQt
VERSION= 3.2
DISTNAME= ${NAME}${VERSION}
PKGNAME= ${PKGTAG.python-}${PKGTAG.qt-}${NAME}-${VERSION}
PKGNAME= ${PKGTAG.python-}${NAME}-${VERSION}
HOMEPAGE= ${MASTER_SITE_GITHUB:=${ORG}/${NAME}}
MASTER_SITES= ${MASTER_SITE_OPENROBOTS:=${NAME}/}
......@@ -19,7 +19,6 @@ COMMENT= Dynamic Python binding for Qt Applications
LICENSE= gnu-lgpl-v2.1
MAINTAINER= guilhem.saurel@laas.fr
QMAKE_ARGS+= QT_MAJOR_VERSION=${QT_SELECT}
QMAKE_ARGS+= CONFIG+=release
SUBST_CLASSES+= py-ver
......
# robotpkg depend.mk for: wip/py38-qt5-PythonQt
# robotpkg depend.mk for: wip/py38-PythonQt
# Created: Guilhem Saurel on Wed, 27 May 2020
#
DEPEND_DEPTH:= ${DEPEND_DEPTH}+
PY_QT_PYTHONQT_DEPEND_MK:= ${PY_QT_PYTHONQT_DEPEND_MK}+
PY_PYTHONQT_DEPEND_MK:= ${PY_PYTHONQT_DEPEND_MK}+
ifeq (+,$(DEPEND_DEPTH))
DEPEND_PKG+= py-qt-pythonqt
DEPEND_PKG+= py-pythonqt
endif
ifeq (+,$(PY_QT_PYTHONQT_DEPEND_MK)) # ------------------------------------------
ifeq (+,$(PY_PYTHONQT_DEPEND_MK)) # ------------------------------------------
PREFER.py-qt-pythonqt?= robotpkg
PREFER.py-pythonqt?= robotpkg
SYSTEM_SEARCH.py-qt-pythonqt= \
SYSTEM_SEARCH.py-pythonqt= \
'include/PythonQt/PythonQt.h' \
'lib/libPythonQt-Qt5-Python${PYTHON_VERSION}.so'
DEPEND_USE+= py-qt-pythonqt
DEPEND_USE+= py-pythonqt
DEPEND_ABI.py-qt-pythonqt?= ${PKGTAG.python}-${PKGTAG.qt}-PythonQt>=3.2
DEPEND_DIR.py-qt-pythonqt?= ../../wip/py-qt-pythonqt
DEPEND_ABI.py-pythonqt?= ${PKGTAG.python}-PythonQt>=3.2
DEPEND_DIR.py-pythonqt?= ../../wip/py-pythonqt
include ../../mk/sysdep/python.mk
include ../../mk/sysdep/qt.mk
endif # PY_QT_PYTHONQT_DEPEND_MK ------------------------------------------------
endif # PY_PYTHONQT_DEPEND_MK ------------------------------------------------
DEPEND_DEPTH:= ${DEPEND_DEPTH:+=}
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment