Commit 94f6b616 authored by Guilhem Saurel's avatar Guilhem Saurel
Browse files

[CMake] silence boost python warning on boost bind

Boost 1.73 added a boring warning about deprecated use of boost bind,
which is still used by boost python.

As of Boost 1.75, this is still not fixed:
boostorg/python#296
boostorg/python#315

ref https://github.com/stack-of-tasks/eigenpy/pull/216
parent 48c539c0
......@@ -44,6 +44,12 @@ IF(BUILD_PYTHON_INTERFACE)
SEARCH_FOR_BOOST_PYTHON(REQUIRED)
STRING(REGEX REPLACE "-" "_" PYTHON_DIR ${CUSTOM_HEADER_DIR})
ADD_PROJECT_DEPENDENCY(dynamic-graph-python 4.0.0 REQUIRED)
IF(Boost_VERSION GREATER 107299)
# Silence a warning about a deprecated use of boost bind by boost python
# at least fo boost 1.73 to 1.75
ADD_DEFINITIONS(-DBOOST_BIND_GLOBAL_PLACEHOLDERS)
ENDIF()
ENDIF(BUILD_PYTHON_INTERFACE)
# Main Library
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment