Commit 2adf7786 authored by Sébastien Barthélémy's avatar Sébastien Barthélémy

cmake: fix pkg-config version constraints

to make them compatible wih perl's implementation [1] of pkg-config.

See [2] for more details.

[1] https://metacpan.org/pod/PkgConfig
[2] https://github.com/jrl-umi3218/jrl-cmakemodules/pull/265
parent e4363c60
......@@ -74,18 +74,18 @@ ENDMACRO(TAG_LIBRARY_VERSION)
# ----------------------------------------------------
# --- DEPENDENCIES -----------------------------------
# ----------------------------------------------------
ADD_REQUIRED_DEPENDENCY("eigen3 >= 3.0.5")
ADD_REQUIRED_DEPENDENCY("eigen3>=3.0.5")
IF(BUILD_WITH_URDF_SUPPORT)
ADD_REQUIRED_DEPENDENCY("urdfdom >= 0.2.0")
ADD_REQUIRED_DEPENDENCY("urdfdom>=0.2.0")
ENDIF(BUILD_WITH_URDF_SUPPORT)
IF(BUILD_WITH_COLLISION_SUPPORT)
ADD_REQUIRED_DEPENDENCY("hpp-fcl >= 1.0.0")
ADD_REQUIRED_DEPENDENCY("hpp-fcl>=1.0.0")
ENDIF(BUILD_WITH_COLLISION_SUPPORT)
IF(BUILD_WITH_AUTODIFF_SUPPORT)
ADD_REQUIRED_DEPENDENCY("cppad >= 20180000.0")
ADD_REQUIRED_DEPENDENCY("cppad>=20180000.0")
ENDIF(BUILD_WITH_AUTODIFF_SUPPORT)
IF(CPPAD_FOUND AND BUILD_WITH_AUTODIFF_SUPPORT)
......@@ -106,7 +106,7 @@ IF(CPPAD_FOUND AND BUILD_WITH_AUTODIFF_SUPPORT)
ENDIF(CPPAD_FOUND AND BUILD_WITH_AUTODIFF_SUPPORT)
IF(BUILD_WITH_CASADI_SUPPORT)
ADD_REQUIRED_DEPENDENCY("casadi >= 3.4.5")
ADD_REQUIRED_DEPENDENCY("casadi>=3.4.5")
ENDIF(BUILD_WITH_CASADI_SUPPORT)
IF(CASADI_FOUND AND BUILD_WITH_CASADI_SUPPORT)
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment