Commit 17948ff2 authored by Guilhem Saurel's avatar Guilhem Saurel
Browse files

[CMake] workaround boost bind warnings

parent ed550e2d
...@@ -37,6 +37,12 @@ IF(BUILD_TESTING) ...@@ -37,6 +37,12 @@ IF(BUILD_TESTING)
FIND_PACKAGE(Boost REQUIRED COMPONENTS unit_test_framework) FIND_PACKAGE(Boost REQUIRED COMPONENTS unit_test_framework)
ENDIF(BUILD_TESTING) ENDIF(BUILD_TESTING)
IF(Boost_VERSION GREATER 107299 OR Boost_VERSION_MACRO GREATER 107299)
# Silence a warning about a deprecated use of boost bind by boost >= 1.73
# without dropping support for boost < 1.73
ADD_DEFINITIONS(-DBOOST_BIND_GLOBAL_PLACEHOLDERS)
ENDIF()
# Main Library # Main Library
SET(${PROJECT_NAME}_HEADERS SET(${PROJECT_NAME}_HEADERS
include/${CUSTOM_HEADER_DIR}/api.hh include/${CUSTOM_HEADER_DIR}/api.hh
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment