Commit 8caf7a20 authored by Anthony Mallet's avatar Anthony Mallet
Browse files

[graphics/kpp-interfacewalk] Delete obsolete package

This package is not developed anymore, and depends on non-existent kineoworks
package. So it is unlikely to be useful to anyone.

OK Florent, Guilhem
parent bcb79ff0
......@@ -15,7 +15,6 @@ SUBDIR+= grh2
SUBDIR+= hpp-gepetto-viewer
SUBDIR+= jafar-gdhe
SUBDIR+= kpp-interface
SUBDIR+= kpp-interfacewalk
SUBDIR+= laaswm
SUBDIR+= laaswm-libs
SUBDIR+= openvrml-libs
......
kppInterfaceWalk is a graphical user interface for hppWalkPlanner libraries.
# robotpkg Makefile for: graphics/kpp-interfacewalk
# Created: Anthony Mallet on Wed, 29 Aug 2007
#
DISTNAME= kpp-interfacewalk-${VERSION}
PKGNAME= kpp-interfacewalk-${VERSION}
VERSION= 1.13
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_OPENROBOTS:=kpp-interfacewalk/}
MASTER_REPOSITORY= ${MASTER_REPOSITORY_JRL}kpp/kpp-interfacewalk
MAINTAINER= hpp@laas.fr
#HOMEPAGE=
COMMENT= Graphical user interface for hppWalkPlanner libraries.
LICENSE= cnrs-hpp-closed-source
GNU_CONFIGURE= yes
DOXYGEN_PLIST_DIR+=share/doc/kpp-interfacewalk
# options
PKG_SUPPORTED_OPTIONS+= verbose
PKG_OPTION_DESCR.verbose= Compile in verbose mode
PKG_OPTION_SET.verbose:= CPPFLAGS+=-DHPP_DEBUG
include ../../mk/sysdep/doxygen.mk
include ../../path/hpp-walkplanner/depend.mk
include ../../graphics/kpp-interface/depend.mk
#FIXME? include ../../robots/hrpsys-jrl/depend.mk
include ../../pkgtools/libtool/depend.mk
include ../../pkgtools/pkg-config/depend.mk
include ../../mk/language/c.mk
include ../../mk/language/c++.mk
include ../../mk/robotpkg.mk
@comment Sat Apr 18 14:48:32 JST 2009
@comment Sat Feb 27 15:50:23 CET 2010
include/kpp/interfacewalk/fwd.hh
include/kpp/interfacewalk/interface.hh
include/kpp/interfacewalk/kppinterface-nowarning.hh
lib/modules/${NODENAME}/libkpp-interfacewalk.kab
lib/modules/${NODENAME}/libkpp-interfacewalk.la
lib/pkgconfig/kpp-interfacewalk.pc
@dirrm include/kpp/interfacewalk
# robotpkg depend.mk for: graphics/kpp-interfacewalk
# Created: florent on Fri, 1 May 2009
#
DEPEND_DEPTH:= ${DEPEND_DEPTH}+
KPP_INTERFACEWALK_DEPEND_MK:= ${KPP_INTERFACEWALK_DEPEND_MK}+
ifeq (+,$(DEPEND_DEPTH))
DEPEND_PKG+= kpp-interfacewalk
endif
ifeq (+,$(KPP_INTERFACEWALK_DEPEND_MK)) # ------------------------------------
PREFER.kpp-interfacewalk?= robotpkg
DEPEND_USE+= kpp-interfacewalk
DEPEND_ABI.kpp-interfacewalk?= kpp-interfacewalk>=1.9
DEPEND_DIR.kpp-interfacewalk?= ../../graphics/kpp-interfacewalk
SYSTEM_SEARCH.kpp-interfacewalk=\
include/kppInterfaceWalk/kppInterfaceWalk.h \
'lib/pkgconfig/kppInterfaceWalk.pc:/Version/s/[^0-9.]//gp'
endif # --------------------------------------------------------------------
DEPEND_DEPTH:= ${DEPEND_DEPTH:+=}
SHA1 (kpp-interfacewalk-1.13.tar.gz) = 2e9e94aaf60f9e7ec187005fb17d7d1b1186962d
RMD160 (kpp-interfacewalk-1.13.tar.gz) = 88eb3a21c13e7fd8c7dee445aaca66ce04498506
Size (kpp-interfacewalk-1.13.tar.gz) = 376799 bytes
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment