Commit 794b22c3 authored by Anthony Mallet's avatar Anthony Mallet
Browse files

[graphics/rcpdf-interface] Delete package

This supports only ros <= groovy, which is almost obsolete. This package is
probably not used anymore.

OK Florent
parent c4cfd0a8
......@@ -23,7 +23,6 @@ SUBDIR+= laaswm-libs
SUBDIR+= openvrml-libs
SUBDIR+= pqp
SUBDIR+= primitiveShapes-libs
SUBDIR+= rcpdf
SUBDIR+= robot-capsule-urdf
SUBDIR+= ros-convex-decomposition
SUBDIR+= ros-geometric-shapes
......
Robot Contact Point Description Format interfaces definition
Define the model structure (contacts and model) as C++ classes.
# robotpkg Makefile for: graphics/rcpdf-interface
# Created: Florent Lamiraux on Tue, 30 Jul 2013
#
PKGREVISION= 2
VERSION= 0.2
DISTNAME= rcpdf_interface-${VERSION}
PKGNAME= rcpdf-interface-${VERSION}
MASTER_SITES= ${MASTER_SITE_OPENROBOTS:=rcpdf_interface/}
CATEGORIES= graphics
MAINTAINER= hpp@laas.fr
HOMEPAGE= https://github.com/laas/robot_contact_point
COMMENT= Robot Contact Point Description Format interfaces
LICENSE= 2-clause-bsd
DYNAMIC_PLIST_DIRS+= share/doc/rcpdf_interface
# this uses the deprecated urdf_interface package that was removed in hydro
DEPEND_ABI.ros+= ros<=groovy
include ../../middleware/ros-comm/depend.mk
include ../../graphics/ros-robot-model/depend.mk
include ../../pkgtools/pkg-config/depend.mk
include ../../mk/language/c.mk
include ../../mk/language/c++.mk
include ../../mk/sysdep/cmake.mk
include ../../mk/sysdep/doxygen.mk
include ../../mk/robotpkg.mk
@comment Tue Jul 30 19:59:11 CEST 2013
include/rcpdf_interface/config.h
include/rcpdf_interface/config.hh
include/rcpdf_interface/contact.hh
include/rcpdf_interface/deprecated.hh
include/rcpdf_interface/model.hh
include/rcpdf_interface/warning.hh
lib/pkgconfig/rcpdf_interface.pc
# robotpkg depend.mk for: graphics/rcpdf-interface
# Created: Florent Lamiraux on Tue, 30 Jul 2013
#
DEPEND_DEPTH:= ${DEPEND_DEPTH}+
RCPDF_INTERFACE_DEPEND_MK:= ${RCPDF_INTERFACE_DEPEND_MK}+
ifeq (+,$(DEPEND_DEPTH))
DEPEND_PKG+= rcpdf-interface
endif
ifeq (+,$(RCPDF_INTERFACE_DEPEND_MK)) # --------------------------------------
PREFER.rcpdf-interface?= robotpkg
DEPEND_USE+= rcpdf-interface
DEPEND_ABI.rcpdf-interface?= rcpdf-interface>=0.2
DEPEND_DIR.rcpdf-interface?= ../../graphics/rcpdf-interface
SYSTEM_SEARCH.rcpdf-interface=\
include/rcpdf_interface/model.hh \
include/rcpdf_interface/contact.hh \
'lib/pkgconfig/rcpdf_interface.pc:/Version/s/[^0-9.]//gp'
endif # RCPDF_INTERFACE_DEPEND_MK --------------------------------------------
DEPEND_DEPTH:= ${DEPEND_DEPTH:+=}
SHA1 (rcpdf_interface-0.2.tar.gz) = cfc08018524a633fd8c426f7d953e552e6a4d83b
RMD160 (rcpdf_interface-0.2.tar.gz) = e9b55eba4b891c7e5fbc35aef371a750f3b8fc34
Size (rcpdf_interface-0.2.tar.gz) = 75212 bytes
SHA1 (patch-aa) = 22361851f24e1515d9f680079b7cb81c1e2eb937
Use cmake's idea of the "make" program, so that it can be tuned by robotpkg
https://github.com/jrl-umi3218/jrl-cmakemodules/issues/34
--- cmake/doxygen.cmake~ 2013-07-30 19:48:34.000000000 +0200
+++ cmake/doxygen.cmake 2013-12-14 18:26:08.000000000 +0100
@@ -66,7 +66,7 @@
COMMENT "Generating Doxygen documentation"
)
- INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${MAKE} doc)")
+ INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_MAKE_PROGRAM} doc)")
ENDIF(MSVC)
ADD_CUSTOM_COMMAND(
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment