[CMake] eigenpy is required at runtime

If libeigenpy.so is available at buildtime, and not at runtime, the
python bindings can't work.
20 jobs for master in 10 minutes and 46 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Test
passed #61976
doc-coverage

00:10:42

passed #61977
allowed to fail
format

00:04:11

passed #61959
robotpkg-multicontact-api-16.04-debug

00:04:37

passed #61958
robotpkg-multicontact-api-16.04-release

00:04:28

passed #61961
robotpkg-multicontact-api-18.04-debug

00:00:37

passed #61960
robotpkg-multicontact-api-18.04-release

00:04:58

passed #61963
robotpkg-multicontact-api-stretch-debug

00:00:38

passed #61962
robotpkg-multicontact-api-stretch-release

00:04:57

passed #61965
robotpkg-py-multicontact-api-16.04-debug

00:02:03

passed #61964
robotpkg-py-multicontact-api-16.04-release

00:07:52

passed #61969
robotpkg-py-multicontact-api-18.04-debug

00:10:17

passed #61968
robotpkg-py-multicontact-api-18.04-release

00:09:50

passed #61967
allowed to fail
robotpkg-py-multicontact-api-py3-16.04-debug

00:02:03

passed #61966
allowed to fail
robotpkg-py-multicontact-api-py3-16.04-release

00:07:57

passed #61971
allowed to fail
robotpkg-py-multicontact-api-py3-18.04-debug

00:10:20

passed #61970
allowed to fail
robotpkg-py-multicontact-api-py3-18.04-release

00:10:09

passed #61975
allowed to fail
robotpkg-py-multicontact-api-py3-stretch-debug

00:10:28

passed #61974
allowed to fail
robotpkg-py-multicontact-api-py3-stretch-release

00:10:10

passed #61973
robotpkg-py-multicontact-api-stretch-debug

00:10:28

passed #61972
robotpkg-py-multicontact-api-stretch-release

00:10:20