Commit be639a5c authored by Guilhem Saurel's avatar Guilhem Saurel

[CMake] eigenpy is required at runtime

If libeigenpy.so is available at buildtime, and not at runtime, the
python bindings can't work.
parent 02566625
Pipeline #8226 passed with stage
in 10 minutes and 46 seconds
......@@ -38,7 +38,7 @@ ADD_REQUIRED_DEPENDENCY("pinocchio >= 2.0.0")
SET(BOOST_COMPONENTS unit_test_framework serialization)
IF(BUILD_PYTHON_INTERFACE)
ADD_COMPILE_DEPENDENCY("eigenpy >= 1.3.1")
ADD_REQUIRED_DEPENDENCY("eigenpy >= 1.3.1")
SET(BOOST_COMPONENTS ${BOOST_COMPONENTS} python)
FINDPYTHON()
INCLUDE_DIRECTORIES(SYSTEM ${PYTHON_INCLUDE_DIRS})
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment