Unverified Commit 37c341a4 authored by Guilhem Saurel's avatar Guilhem Saurel Committed by GitHub
Browse files

Merge pull request #158 from nim65s/devel

[CMake] fix GPL lib dependencies
parents 4362a519 34225df5
# Please don't edit this file, and use the version generated at
# http://rainboard.laas.fr/project/hpp-core/.gitlab-ci.yml
variables:
GIT_SUBMODULE_STRATEGY: "recursive"
CCACHE_BASEDIR: "${CI_PROJECT_DIR}"
CCACHE_DIR: "${CI_PROJECT_DIR}/ccache"
cache:
paths:
- ccache
.robotpkg-hpp-core: &robotpkg-hpp-core
except:
- gh-pages
script:
- mkdir -p ccache
- cd /root/robotpkg/path
- git pull
- cd hpp-core
- make checkout MASTER_REPOSITORY="dir ${CI_PROJECT_DIR}"
- make install
- cd work.$(hostname)/$(make show-var VARNAME=DISTNAME)
- make test
robotpkg-hpp-core-16.04-release:
<<: *robotpkg-hpp-core
image: eur0c.laas.fr:5000/humanoid-path-planner/hpp-core/hpp-core:16.04
robotpkg-hpp-core-18.04-release:
<<: *robotpkg-hpp-core
image: eur0c.laas.fr:5000/humanoid-path-planner/hpp-core/hpp-core:18.04
doc-coverage:
<<: *robotpkg-hpp-core
image: eur0c.laas.fr:5000/humanoid-path-planner/hpp-core/hpp-core:16.04
before_script:
- echo -e 'CXXFLAGS+= --coverage\nLDFLAGS+= --coverage\nPKG_DEFAULT_OPTIONS= debug' >> /opt/openrobots/etc/robotpkg.conf
after_script:
- cd /root/robotpkg/path/hpp-core
- cd work.$(hostname)/$(make show-var VARNAME=DISTNAME)
- make doc
- mv doc/doxygen-html ${CI_PROJECT_DIR}
- mkdir -p ${CI_PROJECT_DIR}/coverage/
- gcovr -r .
- gcovr -r . --html --html-details -o ${CI_PROJECT_DIR}/coverage/index.html
artifacts:
expire_in: 1 day
paths:
- doxygen-html/
- coverage/
include: http://rainboard.laas.fr/project/hpp-core/.gitlab-ci.yml
......@@ -125,10 +125,10 @@ ADD_LIBRARY(${LIBRARY_NAME}-gpl
SHARED
path-optimization/quadratic-program.cc
path-optimization/spline-gradient-based.cc)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME} hpp-pinocchio)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME} hpp-util)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME} hpp-statistics)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME} hpp-constraints)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME}-gpl hpp-pinocchio)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME}-gpl hpp-util)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME}-gpl hpp-statistics)
PKG_CONFIG_USE_DEPENDENCY(${LIBRARY_NAME}-gpl hpp-constraints)
TARGET_LINK_LIBRARIES(${LIBRARY_NAME}-gpl ${LIBRARY_NAME})
INSTALL(TARGETS ${LIBRARY_NAME}-gpl DESTINATION lib)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment