Commit 02a0d6c4 authored by jcarpent's avatar jcarpent
Browse files

[CMake] Sync submodule

parent b88eb8fc
Subproject commit 9f9a90007704d679c631431ab36189f7ba61f323 Subproject commit 5663a002a905b5c8d84a69d8e74044a8e34a48ed
...@@ -94,7 +94,7 @@ ENDIF ( ) ...@@ -94,7 +94,7 @@ ENDIF ( )
# ---------------------------------------------------- # ----------------------------------------------------
IF(EIGENPY_FOUND) IF(EIGENPY_FOUND)
FINDPYTHON() FINDPYTHON(2.7 EXACT REQUIRED)
MAKE_DIRECTORY("${${PROJECT_NAME}_BINARY_DIR}/lib/python/${PROJECT_NAME}") MAKE_DIRECTORY("${${PROJECT_NAME}_BINARY_DIR}/lib/python/${PROJECT_NAME}")
# --- COMPILE WRAPPER # --- COMPILE WRAPPER
...@@ -114,7 +114,7 @@ IF(EIGENPY_FOUND) ...@@ -114,7 +114,7 @@ IF(EIGENPY_FOUND)
IF(LUA5_1_FOUND) IF(LUA5_1_FOUND)
PKG_CONFIG_USE_DEPENDENCY(${PYWRAP} lua5.1) PKG_CONFIG_USE_DEPENDENCY(${PYWRAP} lua5.1)
ENDIF(LUA5_1_FOUND) ENDIF(LUA5_1_FOUND)
TARGET_LINK_LIBRARIES(${PYWRAP} ${Boost_LIBRARIES} ${PROJECT_NAME}) TARGET_LINK_LIBRARIES(${PYWRAP} ${Boost_LIBRARIES} ${PROJECT_NAME} ${PYTHON_LIBRARIES})
IF(APPLE) IF(APPLE)
# We need to change the extension for python bindings # We need to change the extension for python bindings
......
...@@ -13,7 +13,7 @@ curl http://robotpkg.openrobots.org/packages/debian/robotpkg.key | sudo apt-key ...@@ -13,7 +13,7 @@ curl http://robotpkg.openrobots.org/packages/debian/robotpkg.key | sudo apt-key
sudo free -m -t sudo free -m -t
# Setup environment variables. # Setup environment variables.
export APT_DEPENDENCIES="doxygen libboost-dev libboost-doc libboost-thread-dev libboost-system-dev libboost-test-dev libboost-filesystem-dev libboost-python-dev libboost-program-options-dev libeigen3-dev libtinyxml-dev robotpkg-urdfdom robotpkg-console-bridge" export APT_DEPENDENCIES="doxygen libboost-dev libboost-doc libboost-thread-dev libboost-system-dev libboost-test-dev libboost-filesystem-dev libboost-python-dev libboost-program-options-dev libeigen3-dev libtinyxml-dev robotpkg-urdfdom libconsole-bridge-dev"
# Add Python dependency # Add Python dependency
export APT_DEPENDENCIES=$APT_DEPENDENCIES" libpython2.7 python-numpy robotpkg-eigenpy" export APT_DEPENDENCIES=$APT_DEPENDENCIES" libpython2.7 python-numpy robotpkg-eigenpy"
# Add Geometry dependencies # Add Geometry dependencies
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment