Commit 9e958838 authored by Guilhem Saurel's avatar Guilhem Saurel
Browse files

remove requirements.*, and use pipenv in docker

parent 5d69eb05
Pipeline #1078 failed with stages
in 5 minutes and 1 second
......@@ -5,8 +5,6 @@ EXPOSE 8000
RUN mkdir /app
WORKDIR /app
ADD requirements.txt ./
RUN apt-get update -qq && apt-get install -qqy \
apt-transport-https \
git \
......@@ -18,12 +16,16 @@ RUN apt-get update -qq && apt-get install -qqy \
&& echo "deb [arch=amd64] https://download.docker.com/linux/debian jessie stable" >> /etc/apt/sources.list \
&& apt-get update -qq && apt-get install -qqy docker-ce
RUN pip3 install --no-cache-dir -r requirements.txt \
RUN pip3 install --no-cache-dir \
gunicorn \
ipython \
pipenv \
psycopg2-binary \
python-memcached
ADD Pipfile Pipfile.lock ./
RUN pipenv install --system --deploy
ADD . .
CMD /srv/dashboard/robotpkg/bootstrap/bootstrap \
......
ndh
django-filter
django-tables2
gitpython
requests
#
# This file is autogenerated by pip-compile
# To update, run:
#
# pip-compile --output-file requirements.txt requirements.in
#
certifi==2018.1.18 # via requests
chardet==3.0.4 # via requests
django-autoslug-iplweb==1.9.4.dev0 # via ndh
django-bootstrap4==0.0.6 # via ndh
django-filter==1.1.0
django==2.0.4 # via django-tables2, ndh
gitdb2==2.0.3 # via gitpython
gitpython==2.1.9
idna==2.6 # via requests
ndh==3.5.1
pytz==2018.4 # via django
requests==2.18.4
smmap2==2.0.3 # via gitdb2
urllib3==1.22 # via requests
https://github.com/jieter/django-tables2/archive/master.zip
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment